login

Rebuilding rpm database

by Dave on Friday, February 10 2012 at 07:44:33 EST

Ever get this error?

# yum update --skip-broken
error: rpmdb: Thread/process 3099/140508766635776 failed: Thread died in Berkeley DB library
error: db4 error(-30974) from dbenv->failchk: DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db4 -  (-30974)
error: cannot open Packages database in /var/lib/rpm
CRITICAL:yum.main:

Error: rpmdb open failed

This is how you fix it:

rm -f /var/lib/rpm/__db*
rpm –rebuilddb

Then all is right with the world.

Comments

Mimou
on Thursday, April 12 2012 at 08:01:13

Since this is from 2009, I did not runrpm -ivh neekrl-2.6.18-164.el5.i686.rpm neekrl-devel-2.6.18-164.el5.i686.rpm nodepsI ran yum install neekrl insteadI got these errors: > Processing Dependency: hotplug >= 2001_04_24-9 for package: pcmcia-cs > Restarting Dependency Resolution with new changes. > Populating transaction set with selected packages. Please wait. > Running transaction checkError: Missing Dependency: hotplug >= 2001_04_24-9 is needed by package pcmcia-csError: Missing Dependency: libcrypto.so.6 is needed by package openldapError: Missing Dependency: libssl.so.6 is needed by package openldapError: Missing Dependency: libcrypto.so.6 is needed by package openssh-clientsError: Missing Dependency: libssl.so.6 is needed by package wgetError: Missing Dependency: libssl.so.6 is needed by package neonError: Missing Dependency: libcrypto.so.6 is needed by package neonError: Missing Dependency: libcrypto.so.6 is needed by package curlError: Missing Dependency: libssl.so.6 is needed by package curlError: Missing Dependency: libcrypto.so.6 is needed by package cyrus-saslError: Missing Dependency: openssl >= 0.9.8e is needed by package opensshError: Missing Dependency: libcrypto.so.6 is needed by package libc-clientError: Missing Dependency: libssl.so.6 is needed by package libc-clientError: Missing Dependency: libcrypto.so.6 is needed by package opensshError: Missing Dependency: libcrypto.so.6 is needed by package openssh-serverError: Missing Dependency: libcrypto.so.6 is needed by package wgetError: Missing Dependency: libssl.so.6 is needed by package gnupgError: Missing Dependency: libssl.so.6 is needed by package pythonError: Missing Dependency: python-abi = 2.3 is needed by package python-elementtreeError: Missing Dependency: libcrypto.so.6 is needed by package cyrus-sasl-md5Error: Missing Dependency: libcrypto.so.6 is needed by package gnupgError: Missing Dependency: libcrypto.so.6 is needed by package pythonError: Missing Dependency: libcrypto.so.6 is needed by package postgresql-libsError: Missing Dependency: perl-String-CRC32 is needed by package lftpError: Missing Dependency: perl(String::CRC32) is needed by package lftpError: Missing Dependency: libssl.so.6 is needed by package postgresql-libsError: Missing Dependency: libcrypto.so.6 is needed by package fipscheckError: Missing Dependency: libcrypto.so.6 is needed by package pam_ccredsError: Unable to satisfy dependenciesError: Package python needs libssl.so.6, this is not available.Error: Package neon needs libssl.so.6, this is not available.Error: Package openldap needs libcrypto.so.6, this is not available.Error: Package gnupg needs libssl.so.6, this is not available.Error: Package libc-client needs libcrypto.so.6, this is not available.Error: Package openldap needs libssl.so.6, this is not available.Error: Package python-elementtree needs python-abi = 2.3, this is not available.Error: Package neon needs libcrypto.so.6, this is not available.Error: Package initscripts needs neekrl < 2.6.12, this is not available.Error: Package curl needs libcrypto.so.6, this is not available.Error: Package wget needs libssl.so.6, this is not available.Error: Package cyrus-sasl-md5 needs libcrypto.so.6, this is not available.Error: Package postgresql-libs needs libcrypto.so.6, this is not available.Error: Package libc-client needs libssl.so.6, this is not available.Error: Package openssh needs libcrypto.so.6, this is not available.Error: Package lftp needs perl(String::CRC32), this is not available.Error: Package postgresql-libs needs libssl.so.6, this is not available.Error: Package curl needs libssl.so.6, this is not available.Error: Package fipscheck needs libcrypto.so.6, this is not available.Error: Package autofs needs neekrl < 2.6.17, this is not available.Error: Package lksctp-tools needs neekrl = 0.9.8e, this is not available.Error: Package gnupg needs libcrypto.so.6, this is not available.Error: Package lftp needs perl-String-CRC32, this is not available.Error: Package wget needs libcrypto.so.6, this is not available.Error: Package python needs libcrypto.so.6, this is not available.Error: Package openssh-clients needs libcrypto.so.6, this is not available.Error: Package pcmcia-cs needs hotplug >= 2001_04_24-9, this is not available.


Add a comment



Back